Welcome! Log In Create A New Profile

Advanced

Not finding parts numbers in search

Posted by neuroticartist 
Not finding parts numbers in search
September 04, 2007 08:06AM
I have a we4bsite here:
http://www.lightparts.com

I have many php pages for different concert lighting and the parts for sale to replace or fix hundreds of different models. Thousands of parts.

Lets say you have a High End Trackspot light and need to replace a part with the part number 80270003

that part number is found on this page:
http://www.lightparts.com/highend/trackspot_list.php

80270003 FAN,SUNON MODIFIED ASSY $26.60

When I do a search for a part number it finds it in others but not always in the one I want it to find. It should be finding it in every page its in.

if I do a search for 80270003 trackspot it finds nothing.

The part numbers, names and pricves are pasted from an xls (Excel spreadsheet) table into the body of the page and pastes as a table.

Ive indexed several times but it just doesnt seem to find what Im looking for. My client says searching by part number is very important to this site.

what can I do? Any ideas?

Thanks!
Roz
neuroticartist@yahoo.com
http://www.naimultimedia.com
rec
Re: Not finding parts numbers in search
September 04, 2007 03:28PM
More exactly, to who whants to help

You can find a number
80010052

http://www.lightparts.com/sphider/lp_search.php?query=80010052&search=1&submit.x=29&submit.y=7

But you can't find another number
99320075

http://www.lightparts.com/sphider/lp_search.php?query=99320075&search=1&submit.x=23&submit.y=7
Re: Not finding parts numbers in search
September 04, 2007 09:06PM
yes it seems to be random on what it finds and what it doesnt.
go to any light page and copy a part number then search for it and see if it finds that page, it usually doesnt. Im not sure what I can do to fix it because its so random :-/
Re: Not finding parts numbers in search
September 05, 2007 04:27PM
I indexed the page and had no problem finding the numbers.
Try to isolate a case where you index one page, and can find some numbers and not the others. Then report back and we can start debugging what might be the case.
Re: Not finding parts numbers in search
September 11, 2007 03:10AM
Go to the home page:
http://www.lightparts.com

Type 80050034 into the "website search" on the home page. You get the
"need zone listing" but you don't get a hit for the parts price list found here,
10th item down:
http://www.lightparts.com/highend/studio-color575_list.php
should have also gotten a hit here too, 8th item down:
http://www.lightparts.com/highend/studio-spot-575_list.php

It's a popular part, that's why I chose it as an example.

I dont understand why its not finding it.
Re: Not finding parts numbers in search
September 11, 2007 03:23AM
OK I indexed this page separately, just this specific page then did a search and it found the part. But I have a hundred pages like this, how come it wont catalog it when I index the entire site?
Re: Not finding parts numbers in search
September 11, 2007 07:17AM
it skips the page?


word count on the page less than 10?

duplicate page somewhere on the site where it thinks it has already index it due to checksum of the page?

php timing out on your server before it finishes all pages?

check your php ini file

max_execution_time = 0 ; Maximum execution time of each script, in seconds
max_input_time = 0 ; Maximum amount of time each script may spend parsing request data
memory_limit = 500M ; Maximum amount of memory a script may consume (8Mcool smiley *****

the max memory item may be your problem I think it defaults to 8meg and if your script is writing to the screen/ browser a lot of information it might exceed 8meg. If it's not your server be careful on setting this your hosting company might give you a hard time if you change this...
Re: Not finding parts numbers in search
September 11, 2007 07:46AM
BTW 500meg is a lot of ram, try something like 128 meg first.

I use 500meg to load 25 gig of data into a database with huge amounts of echos so I can watch the progress. You shouldn't need this much.
Re: Not finding parts numbers in search
September 11, 2007 12:35PM
neuroticartist Wrote:
-------------------------------------------------------
> OK I indexed this page separately, just this
> specific page then did a search and it found the
> part. But I have a hundred pages like this, how
> come it wont catalog it when I index the entire
> site?


The most typical problem is that Sphider doesnt find links to this site. Maybe they are given bia javascript, forms or something similar.
Sorry, only registered users may post in this forum.

Click here to login