Welcome! Log In Create A New Profile

Advanced

php sphider.php -all does not really execute!

Posted by Josh 
php sphider.php -all does not really execute!
April 06, 2007 09:11AM
Hi all

I'm re-indexing my webs every night using a cron job:

/opt/lampp/bin/php /opt/lampp/htdocs/sphider/admin/spider.php -all

Sadly this command seems to have finished already a second after executing it, which is impossible. When manually clicking on the "Re-index all" link in the admin panel it takes about 15mins until it has finished!

I don't see the mistake I've probably made, maybe you?

Thanks for help,
Josh
Re: php sphider.php -all does not really execute!
April 07, 2007 02:41PM
I'm having the same problem, hopefully someone has the answer!

Gilman
Re: php sphider.php -all does not really execute!
April 09, 2007 07:26PM
Have you try running in using the shell first, this may give you some error message or something that will help.

Diego Medina
[url=http://www.fmpwizard.com]Web Developer[/url]
Anonymous User
Re: php sphider.php -all does not really execute!
April 09, 2007 09:23PM
It happened to me a few times. I got the solution reindexing with 20 levels option, then going back to the number I wanted.

I did it twice in 3 local sites. I am not sure about the reason, nor why the turn around worked.
Anonymous User
Re: php sphider.php -all does not really execute!
April 17, 2007 08:45PM
I found the following explanation somewhere
http://drupal.org/node/104816#comment-182606


"...No significant search engines actually DO their re-indexing all in one-click from a web console. Search indexing isusually an intensive process that cannot be completed in the space of one http page-load.

What happens when you click 're-index' content (even on those other search engines) is in fact a job is added to a schedule of things to do. It doesn't actually do it that instant..."
Sorry, only registered users may post in this forum.

Click here to login