Welcome! Log In Create A New Profile

Advanced

Searching for terms with dots (points) doesn't work

Posted by h-o 
h-o
Searching for terms with dots (points) doesn't work
June 05, 2015 02:51PM
hi,

Sphider works fine on my homepages (after I updated the code of version 1.3.6 manually with the mysqli* commands instead of the mysql* commands in order to prevent the "deprecated" notices in PHP 5.6).

The only thing not works is the search for terms with dots (points) like an item number (e. g. for an article) as follows:

1234.56.789

I have read some topics like this one: http://www.sphider.eu/forum/read.php?2,68

I changed the line in sphiderfuncs.php and re-indexed. Terms with one or more dots/points are indexed now (they can be found in the mySQL-table "keywords" with a tool like phpmyadmin).

But unfortunately, a search with Sphider for this terms with dots is still not successful ("The search 1234.56.789 did not match any documents"winking smiley. It doesn't matter if one searches for 1234.56.789 or only for 1234.56. or only 1234.

What has to be changed in the code, so that Sphider can find these terms in the database?

Or have I to change some settings? "Index numbers" ist selected, "Mininum word length" is 2. I tried with "word stemming" and without "word stemming" (after re-index).

But Sphider doesn't find these terms with dots or points.

Thank you very much for your help in advance.

ciao
h-o
Sorry, only registered users may post in this forum.

Click here to login