password not authenticating / linking for admin.php
July 05, 2015 03:28PM
Hello,

Just downloaded sphider - glad there is a free prgm to install search engines. Thank you.

I added username and pwd to auth.php, but when I log in, it does not connect me to admin.php. I keep getting the log in form.

Probably just a quick php fix on the auth.php page where it links to the admin.php?

Thank you.
Tec
Re: password not authenticating / linking for admin.php
July 06, 2015 02:55PM
For a first test, use the default 'admin' 'admin' to log in. If this does not work for you, verify the session control settings of your server environment. Also ensure that
PHP safe_mode = Off

Tec
Re: password not authenticating / linking for admin.php
July 06, 2015 04:30PM
Thank you for the response.

I deleted include"auth.php" at line 11 of the admin.php script to just get into the page from the browser.

I'll add my own authentication same as the rest of my admin area on the server. I think a good work-around for me.
Re: password not authenticating / linking for admin.php
July 06, 2015 04:49PM
OK, just deleting that line of code gets admin.php to come up, but now it's riddled with error messages.

Using admin admin did not work. I had updated the username and password, so I am not sure how it could? Perhaps I am missing something here.

I'm not sure what you mean by "session control setting of your server environment". I'm using cPanel and phpMyAdmin. I've loaded all the sphider files into the File Manager and have linked to the admin.php page from my website's start up page in the admin area.

I think there is code in the auth.php that is wonky? But, I am a beginner so not really one to gauge that.
Sorry, only registered users may post in this forum.

Click here to login