Welcome! Log In Create A New Profile

Advanced

Sphider slow

Posted by grsmith 
Sphider slow
April 20, 2007 04:38AM
Hi...
I am running Sphider as a personal search for my genealogy research. When I first installed it all was well. I was indexing about 10 different sites. I killed all the sites and did a full index on just on two sites. Now it has developed a small problem...After the first call to the admin script it get slower and slower. It will start to index but then the server times out with a CGi script error. I have 1 gig of memory and it is on a dedicated server. I know this is not much info but I sure would like to pick someone's brain over this.
George
Anonymous User
Re: Sphider slow
April 20, 2007 03:42PM
Use

memory_limit = 256M

in

"php.ini"

and
See

time-out rules in your server
Re: Sphider slow
April 20, 2007 08:12PM
Thanks
Anonymous User
Re: Sphider slow
April 24, 2007 12:22AM
Congratulations
Re: Sphider slow
April 30, 2007 08:44PM
I actually do disagree with the rest of the posts! The memorylimit has nothing to do with your timeouts! PHP by default has a script timeout limit of 30 secs. Increasing this to 60 may improve stability! You may want to look for php.ini (location varies depending on the Lamp box you are using!
Increasing PHP memory_limit as stated in a prior message is tricky! If you have way more than 1 gig you may use the 256 MB, but think of the overall load and also the database overhead when designing your memory usage map!

Andreas
Sorry, only registered users may post in this forum.

Click here to login