Welcome! Log In Create A New Profile

Advanced

i get the output 'Duplicate entry '0' for key 1', what's the problem?

Posted by ahsanmani 
i get the output 'Duplicate entry '0' for key 1', what's the problem?
May 20, 2007 04:15PM
I dont know if this problem has been raised here or not. If yes, then I am so sorry.

I am facing a problem. While I index a page with Sphider then I get the following message/output. I need to know if this is ok or not, and if not then what is my fault or what should I do to get the excat result.

Please help me. Its urgent.

-------------------------------------------------------------------------
1. Retrieving: http://www.****.com/ at 22:16:54.
Size of page: 6.47kb. Starting indexing at 22:16:54. Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1 Re-indexed
Links found: 12. New links: 12
2. Retrieving: http://www.****.com/cybercorner.php at 22:16:54.
Size of page: 4.32kb. Starting indexing at 22:16:54. Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1
Indexed
Links found: 7. New links: 0
3. Retrieving: http://www.****.com/EventsNNewsDetail.php?nid=0 at 22:16:54.
Size of page: 5.00kb. Starting indexing at 22:16:54. Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1
Indexed
Links found: 8. New links: 1
4. Retrieving: http://www.****.com/EventsNNewsDetail.php?nid=41 at 22:16:54.
Size of page: 5.62kb. Starting indexing at 22:16:54. Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1Duplicate entry '0' for key 1
Indexed
Links found: 8. New links: 0
----------------------------------------------------------------------

Thanks in advance.
Re: i get the output 'Duplicate entry '0' for key 1', what's the problem?
May 21, 2007 02:07PM
Seems like a bug in sphider. Send me the link to the url you indexed, ill try to find out more.
Re: i get the output 'Duplicate entry '0' for key 1', what's the problem?
May 24, 2007 04:50PM
Sounds like your SQL tables are setup wrong, most likely you do not have a primary key specified including auto increment for the id fields.
Sorry, only registered users may post in this forum.

Click here to login